我在一個(gè)包中有一些結(jié)構(gòu),它們進(jìn)行簡(jiǎn)單的金融 API 調(diào)用,一個(gè)實(shí)現(xiàn)對(duì) API 的請(qǐng)求,一個(gè)存儲(chǔ)響應(yīng)。我想知道分別將結(jié)構(gòu)命名為“Request”和“Response”是否合適,或者我應(yīng)該在它們前面加上主題/包——比如“FinanceRequest”和“FinanceResponse”?或者通過(guò)使用finance.FinanceRequest(財(cái)務(wù)詞使用兩次)會(huì)使外部調(diào)用變得多余嗎?尋找關(guān)于此事的想法(golang 約定/偏好)...樣品:package financetype Request struct {//...}type Response struct {//...} func DoSomething(r *Request) (*Response, error) {//...}或者package financetype FinanceRequest struct {//...}type FinanceResponse struct {//...} func DoSomething(r *FinanceRequest) (*FinanceResponse, error) {//...}
結(jié)構(gòu)命名約定
天涯盡頭無(wú)女友
2021-12-20 10:08:03